Working with Nammu

Nammu is a simple text editor, written especially for Oracc by UCL's Research Development Software Group [http://www.ucl.ac.uk/research-it-services/research-software-development], that enables all content creators to edit ATF files, one file at at time.

On this page we discuss:

How to install and set up Nammu

It's really easy to install Nammu:

  1. Follow this link to the Github Nammu downloads page [https://github.com/oracc/nammu/releases].
  2. Double-click on the name of the latest release of Nammu, which will have a name like nammu-0.7.0.jar.
  3. Save the download to wherever you want it to live on your own computer.
  4. Open it by double-clicking on the Nammu icon.

Troubleshooting

If you're an advanced user, and want to edit Nammu's configuration file, read the instructions on Github [https://github.com/oracc/nammu#nammus-configuration-for-advanced-users].

Keyboard shortcuts

We hope you will find Nammu very easy intuitive to use. Explore the items in the five drop-down menus, and hover your cursor over the icons at the top of the Nammu window to see what they do. In addition you can use these keyboard shortcuts:

Action Keystroke
New File Ctrl/Cmd + N
Open File Ctrl/Cmd + O
Close File Ctrl/Cmd + W
Save As Ctrl/Cmd + E
Save File Ctrl/Cmd + S
Validate Ctrl/Cmd + D
Lemmatise Ctrl/Cmd + L
Undo Ctrl/Cmd + Z
Redo Ctrl/Cmd + Y
Find Ctrl/Cmd + F
Find next Ctrl/Cmd + G
Replace all Ctrl/Cmd + A
Replace one Ctrl/Cmd + R
Show Help Ctrl/Cmd + H
Split Editor Horizontally Ctrl/Cmd + .
Split Editor Vertically Ctrl/Cmd + ;
Syntax Highlight Switch Ctrl/Cmd + T

If you're already used to editing ATF in Emacs, this should all seem very familiar. If not, we give some more detailed help below.

How to create and save files in Nammu

The current version of Nammu only works with files that are on your own computer. You cannot create or save files direct to the Oracc server. If you're used to doing that, we recommend instead that you pull your files off Oracc before you start editing and then, at the end of your session, upload edited files back to Oracc. We describe how to do that on a separate page [which does not yet exist].

Creating a new ATF file

You can create a new file in Nammu with the File -> New menu item, or by clicking the first icon in the toolbar, or by typing Ctrl/Cmd + N. They all give the same result: a new dialogue box headed "New ATF Template". If you don't want to use this template, simply choose the "Leave blank" option in the bottom centre and the dialogue box will disappear.

Assuming you do want to use the template, each of the text boxes should be self-explanatory, but if not, the help icons on the right will tell you what to do. The completed dialogue box should look something like this:

CDLI's ID: &P123445 = CT 165, pl. 9
Project: saao / saa72
Language: Neo-Assyrian

Then choose "Create template". Nammu will auto-fill the main editing window with the text that you entered, e.g.,:

&P123445 = CT 165, pl. 9
#project: saao/saa72
#atf: lang akk-x-neoass

and will remember your choice of project and language for next time. But you can overwrite Nammu's pre-selections at any time, either in the dialogue box, or in the main editing window.

Nammu does not auto-save your files. Remember to save at regular intervals, so that you don't accidentally lose data.

Saving files

When you save a file for the first time, Nammu will open a "Save" dialogue box, just like any word processor, with all the usual options.

When you name your file, remember that you:

If your filename doesn't obey these simple rules, your file may not work properly with Nammu or with Oracc.

By default, Nammu will suggest you save files to the same same place as Nammu itself. But you can choose a different folder/directory with the "Settings" dialogue box. You'll find this via the File menu, or the cog-wheel icon in the toolbar. Change your "working directory" by clicking "Browse" and selecting the folder/directory where you want to save (and open) your ATF files. You can change this setting as often as you like.

How to edit ATF files in Nammu

We have designed Nammu to be quite intuitive to use. You can cut and paste, find and replace, etc., just as in any text editor. Here are a few things you might not know about:

Validating and lemmatising
Unlike Emacs, you don't have to save a file before you validate or lemmatise it. But, as before, you can only lemmatise a valid file. So fix any validation errors before you lemmatise. Click on an error message in the console at the bottom of the window to go to it in the main editing window.
Split screen
You can split the window, horizontally or vertically. Find these options in the Window menu or in the keyboard shortcuts. This option is particularly useful when you are translating and lemmatising at the same time.

If you're an advanced user of Emacs, you won't find every single editorial feature that you're used to. If you're really missing something, though, please put in a request for it.

How to report bugs and request improvements to Nammu

If you want to ask questions, report bugs, or request new features please contact us by creating a New Issue with the green button on Nammu's Github Issues page [https://github.com/oracc/nammu/issues].

20 Jul 2017 osc at oracc dot org
 
Back to top ^^
 

Released under a Creative Commons Attribution Share-Alike license 3.0, 2014. [http://www.facebook.com/opencuneiform] [http://oracc.blogspot.com] [http://www.twitter.com/oracctivity]
Oracc uses cookies only to collect Google Analytics data. Read more here; see the stats here [http://www.seethestats.com/site/oracc.museum.upenn.edu]; opt out here.

http://oracc.museum.upenn.edu/doc/help/nammuandemacs/nammu/